Jump to content


Xperia X1 - HardSPL, StockSPL czyli odblokowywanie BootLoadera


  • Please log in to reply
1 reply to this topic

#1 OFFLINE   SaimON

SaimON

    Autor najlepszego postu grudnia 2012 i stycznia 2013

  • User
  • 105 posts
    • Time Online: 4d 5h 50m

Posted 31 December 2012 - 14:07

XPERIA X1 - Flashowanie domowym sposobem czyli odblokowywanie BootLoadera poprzez HardSPL i przywracanie oryginalnego poprzez StockSPL


Posted Image





Drodzy posiadacze Xperii X1, zastanawiacie się pewnie jak domowym sposobem "przeflashować" nasz telefon tak, abyśmy mogli instalować ROMy inne niż te oryginalne. Dokonamy tego za pomocą Hard - SPL. Jest to dość prosta i szybka metoda a ryzyko, że coś uszkodzimy jest bardzo małe.



!!!UWAGA!!! Wszelkie czynności wykonujecie na własną odpowiedzialność i ani autor ani niniejsze forum nie ponosi odpowiedzialności za ew. uszkodzenia telefonu. !!!UWAGA!!!



!!!UWAGA 2: Do wykonania wszystkich czynności, potrzebujemy komputera z systemem Windows XP, Vista lub 7. Windows 8 nie jest obsługiwany przez Windows Mobile Device Center!


ROZPOCZNIJMY


Najpierw zajmiemy się przygotowaniem urządzenia i pobraniem wszystkich niezbędnych plików.

1. Przygotuj:

- Telefon z naładowaną bateria w przynajmniej 50% (zalecana wartość to 80%)
- Kabel Mini USB z wtyczką USB (Ten do transmisji danych)

2. Pobierz:

-Sterowniki "NET. Framework" i zainstaluj je na swoim komputerze:

Please Login HERE or Register HERE to see this link!


-Program "Windows Mobile Device Center" i zainstaluj go na swoim komputerze:

Please Login HERE or Register HERE to see this link!


-Program "HardSPL":

Please Login HERE or Register HERE to see this link!


-Paczkę "ruusigned_072stockspl.zip":

Please Login HERE or Register HERE to see this link!



Załączniki dostępne na końcu posta.

3. Zrób:

4. Przenieś wszystkie pliki do jednego folderu, stwórz dodatkowy pusty folder i rozpakuj do niego paczkę "X1_HardSPL_v1.zip"

5. Zsynchronizuj telefon z WMDC (Panel Sterowania>>>Centrum obsługi urządzeń z systemem Windows Mobile>>>podłącz swój telefon>>>zaznacz na ekranie telefonu opcję "Active Sync">>>naciśnij "Gotowe")

6. Uruchom "X1_HardSPL.exe"

7. Postępuj zgodnie z poleceniami programu

8. Twoja Xperia po zakończeniu wszystkich kroków z programem wejdzie w trzy - kolorowe MENU a po wykonaniu wszystkich czynności sama się zrestartuje

9. Teraz trzeba sprawdzić, czy faktycznie "sflashowaliśmy" urządzenie:

9.1 - Wyłączamy telefon

9.2 - Naciskamy przycisk ściszania a później włączania i trzymamy je dopóki nie ujrzymy 3 - kolorowego MENU (BootLoadera)

9.3 - Jeśli widnieje na nim "0.72.OliNex" lub "0.52.OliNex MFG" to znaczy, że się nam udało i możemy wgrywać nasze ROMy ;)




UWAGI I ROZWIĄZYWANIE PROBLEMÓW:


-przeczytaj instrukcję jeszcze raz ;)
-jeśli w HardSPL wyświetla Ci się błąd o połączeniu to spróbuj zrestartować PC/użyć innego PC/podłączyć kabel USB do innego portu
-jeśli HardSPL się nie uruchamia to kliknij na nim prawym przyciskiem myszy>>>uruchom jako administrator
-proszę pisać do mnie na PW, w miarę możliwości odpiszę


PRZYWRACANIE ORYGINALNEGO SPL (StockSPL)


Może zdarzyć się, że będziemy chcieli wrócić do oryginalnego ROM'u od Microsoftu i zaktualizować go poprzez Update Service. Co należy wtedy zrobić?



1. Uruchamiamy "X1_HardSPL.exe" ale nic nie klikamy, zostawiamy tak jak jest


2. Otwieramy paczkę "ruusigned_072stockspl.zip", którą pobraliśmy wcześniej i wklejamy  "RUU_Signed.nbh" do folderu z HardSPL no i oczywiście podmieniamy pliki


3. Dalej postępujemy zgodnie z instrukcjami w poprzedniej części


4. Sprawdzamy, jeśli w oknie BootLoader'a widnieje "0.72.0000" to znaczy, ze przywróciliśmy StockSPL



LINKI DO HSPL I SSPL POCHODZĄ Z SERWISU xda-developers.com. PORADNIK POWSTAŁ DZIĘKI SERWISOWI xda-developers.com. WSZELKIE PRAWA DO KOPIOWANIA NA INNE FORA ZABRONIONE. POZDRAWIAM I ŻYCZĘ UDANEGO FLASHOWANIA, SaimOn :)


not found: Dobra robota, przyklejam. Kolor czerwony zarezerwowany jest dla redakcji, zmieniłem. Poprawiłem też pisownię i wygląd posta ;)

Attached Files


Edited by not found, 31 December 2012 - 14:29.

Posted Image

SE T610 (zgubiony) >>> SE T610 (drugi taki sam; posiadam dalej) >>> Sagem MY400x (posiadam dalej) >>>SE C702 (pierwszy telefon z salonu) >>> Nokia 3110 (posiadam dalej) >>> Huawei U7510 (sprzedany) >>> SE C702 (powrót, posiadam dalej, zalany)>>>SE W910i (sprzedany) >>>SE Elm (sprzedany) >>>SE Xperia X1i (sprzedana) >>> Samsung Omnia Lite (sprzedany) >>> Nokia 5530 (na sprzedaż) + K800i (uszkodzony) >>> Xperia X10 Mini Pro (OBECNY)


#2 OFFLINE   laset111

laset111
  • User
  • 2 posts
    • Time Online: 4h 18m
  • Kraj::
  • Operator: POP

Posted 21 April 2013 - 12:01

Gdy HardSPL zaczyna pracę, na ekranie mojej X1 są kolorowe paski, a następnie kompurter traci połączenie i synchornizację z telefonem, HardSPL wywala błąd z połączeniem i telefon staje, na szczęscie po wyciągnieciu i włożeniu baterii wszystko jest ok. Co mam zrobić żeby program pomyślnie zakończył pracę?




0 user(s) are reading this topic